Results 1 to 4 of 4

Thread: another problem

  1. #1
    Join Date
    Mar 2007
    Posts
    55
    Hello again I have yet again a problem, my Alice Dupont plant has many flower buds but they start to unfold then drop off before they open.I have looked on the site for them but cannot find an answer can any one help please******* :(*:(

  2. #2
    Join Date
    Sep 2003
    Location
    Maryland zone 7
    Posts
    3,042
    Hi there!* A couple of things that come to mind would be overfertilizing with too much nitrogen, overwatering or possibly it's rootbound.* Any of that sound possible?

    Newt

  3. #3
    Join Date
    Mar 2007
    Posts
    55
    Hi Newt* many thanks again I think it may be the pot as it has been in this one for about a year and a half* I don't think I have over watered it but I read on the site you gave me about a little gadget for testing for water in the centre of plants so I shall get one next time I go to the garden centre my next project will be a small olive tree in a pot !!********* Morinja*************** :)

  4. #4
    Join Date
    Sep 2003
    Location
    Maryland zone 7
    Posts
    3,042
    Sounds like it might need a new pot.* If you have pruned the top you could prune the roots and keep it in the same pot.* Don't overfertilize your Mandevilla 'Alice Dupont'.* That could cause the bud drop.* This first site is from Florida in the US but might be helpful.* The second is from California.* Be sure the pot isn't heating up too much from midday sun.
    http://www.floridata.com/ref/M/mandev.cfm
    http://www.californiagardens.com/Pla...illa_alice.htm

    Here's a handy site about growing olives in pots.
    http://www.rhs.org.uk/advice/profiles0701/olives.asp

    Newt

Similar Threads

  1. cucumber problem
    By dommo in forum Growing from Seed
    Replies: 1
    Last Post: 11-28-2009, 02:01 AM
  2. fig tree problem
    By Gary Rose in forum Orchards
    Replies: 1
    Last Post: 08-27-2009, 12:47 PM
  3. Andromeda Problem
    By Bluelinner in forum General Gardening
    Replies: 1
    Last Post: 06-15-2009, 09:42 PM
  4. Nitrogen Problem?
    By UnluckyGardener in forum General Gardening
    Replies: 1
    Last Post: 05-19-2009, 09:58 AM
  5. Gardenia Problem!!!
    By Lily789 in forum House Plants
    Replies: 1
    Last Post: 09-09-2004, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •