Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2013
    Posts
    1

    Confederate Jasmine

    I have a confederate jasmine that is about 20 years old. I have formed it into a shrub around my mail box and it is quite dense with many small branches. No problems up until now. I just found considerable leaf die-back. Entire branches involved. A few leaves are yellow with touches of red. Some leaves show crimson forming among the green. Some leaves have dry spots along the margins and a few have dry holes in the red or yellow area. Most of the dead leaves were on the north east, north and west sides of the plant, which get the least amount of direct sun. The southeast and south sides which get the most direct sun show little damage. I am assuming it is a type of fungus as there is no evidence of insects such as scale. No powdery mildew. There is no galling or discoloration on the branches, but in cutting out the dead leaves I find the branches show no sign of life going back to the main trunk of the vine. We have had a mild winter here in northeast Florida (we refer to this coastal area as zone 8.5). There was a lot of rain in late December/early January.

    I have applied a "systemic fungicide" made by Ferti-lome with propiconazole. Some Web sites recommend using a copper-based fungicide. Any suggestions?

  2. #2
    Try Potassium Bicarbonate.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •