spike & bloom dies on Phaleanopsis

[ Follow Ups ] [ Post Followup ] [ BackyardGardener Orchid Board ]



 

Posted by Kay B. on April 26, 2003 at 07:31:09:

my Phaleanopsis developed a healthy spike in late February which grew about 9 inches..then started to develop what appeared a start of a bloom...soon after that the spike started withering between the the two nodes directly below the bloom..and died...soon after it began dieing, another spike started from the node below the dead section...grew fine...then started a bloom and is now dieing..it weeps and dries up. WHAT IS WRONG ? It is under a grow light..in a South window..folage is strong and growing..watering solution is 20-14-13 by Better Gro...do I need another mixture when it begins to bloom? The plant is very healthy...it was blooming when I got it 2 1/2 years ago...had as many as 11 blooms on it...went through a dormant stage for about a year..then began the new spike I referred to. I will appreciate any and all advice ! Kay

Follow Ups:



Please post your questions on our new message boards.


This message board will not be maintained and is available as an archive.
Name    : 
E-Mail  : 
Subject : 
Comments: Optional Link URL: Link Title: Optional Image URL:


Special thanks to Jane and Bob Rosi for providing this information.

YMCA Camp Loowit Alumni follow me


[ Follow Ups ] [ Post Followup ] [ BackyardGardener Orchid Board ]

WWWBoard © 2001, All Rights Reserved.
Matt Wright and DBasics Software Company
cpe-65-27-22-30.kc.rr.com at 65.27.22.30